{Hướng dẫn} Chỉnh Sửa Url Khi Sử Dụng K2

Thảo luận trong 'Hướng dẫn - Hỏi đáp' bắt đầu bởi hayboy, 26 08 2013.

  1. hayboy

    hayboy Rất nhiệt tình

    Bài viết:
    314
    Được thích:
    65
    Thành tích:
    28
    xa-hoi/item/111-neu-khong-tinh-tao-chung-ta-co-the-lam-hai-cuoc-chien-chong-tham-nhung.html đây là đường dẫn của mình. mình muốn bỏ chữ item thì làm thế nào? Mong mọi người chỉ giúp. Thanks!
  2. Lê Minh Thiện

    Lê Minh Thiện Rất tích cực

    Bài viết:
    88
    Được thích:
    24
    Thành tích:
    8
    bạn vào k2 > parameter >advance rồi chọn No ở "Insert Item id in URL", nếu Joomla 3 thì có thể bỏ được item, còn 2.5 thì mình không rõ lắm, bạn làm thử :)
    hayboykangasai thích bài này.
  3. hayboy

    hayboy Rất nhiệt tình

    Bài viết:
    314
    Được thích:
    65
    Thành tích:
    28
    Trong phần lựa chọn đấy của m để mặc định No rồi. m dùng joomla 2.5.
  4. Lê Minh Thiện

    Lê Minh Thiện Rất tích cực

    Bài viết:
    88
    Được thích:
    24
    Thành tích:
    8
    mình có xem qua rồi, đúng là nó không sửa được trên 2.5, search trên mấy trang khác cũng không có thông tin nhiều, phải ráng tìm hiểu lâu đây, nếu bạn có tìm được cách thì share với anh em luôn nhé :)
  5. ngô đức vũ

    ngô đức vũ Rất tích cực

    Bài viết:
    92
    Được thích:
    13
    Thành tích:
    8
    Cho mình hỏi ké về việc link url với nhé :
    Hiện tại mỗi bài viết mình điều phải ghi alias = tay cho đẹp @@ vì ko ghi để mặc định nó ra quằn quại lắm. Có moduel hoặc plugin nào tự động lấy tiêu đề làm alias không ?
    Mình có đoạn code chuyển Tiêu đề thành tiêu đề không dấu của php, bạn nào rành về viết moduel hay plgin thì viết hộ mình và các bạn đi :)
  6. Lê Minh Thiện

    Lê Minh Thiện Rất tích cực

    Bài viết:
    88
    Được thích:
    24
    Thành tích:
    8
    mình hiểu ý bạn rồi, bạn cần làm các bước sao nè:
    1- vào global config > site > seo setting > chọn No ở Unicode Aliases
    2 - copy file đính kèm vào \libraries\joomla\filter\ (Joomla 2.5)
    Bây giờ bạn có thẻ tạo các bài viết, menu ... mà không cần đặt alias nữa, còn nếu bạn tạo bài viết bằng K2 thì trong paramer, chỗ SEF nó có tùy chỉnh rồi đó ak :)

    Các file đính kèm:

    • output.rar
      Kích thước:
      2,6 KB
      Lượt xem:
      14
    kangasaingô đức vũ thích bài này.
  7. ngô đức vũ

    ngô đức vũ Rất tích cực

    Bài viết:
    92
    Được thích:
    13
    Thành tích:
    8
    tks, chính xác ý mình là như vậy.
    Còn trong K2 để mặc định thì alias nó ra TV có dấu lun @@
  8. hayboy

    hayboy Rất nhiệt tình

    Bài viết:
    314
    Được thích:
    65
    Thành tích:
    28
    có module tạo alias tiếng việt này. nhưng thử trên k2 thì không được.m vào phần seo thay đổi ký tự cũng không được với k2.

    Các file đính kèm:

  9. ==R==

    ==R== Mới tham gia

    Bài viết:
    18
    Được thích:
    2
    Thành tích:
    3
    bỏ item và id bài trong link của k2 làm như sau.
    vào K2 / Parameters / advande / tại mục advande SEF bật Yes phần Enable... tiếp theo chọn No ở 2 mục Used the item...URL và Insert item...URL. Xong
    Alias thì chỉ có plugin cho content thôi, cho K2 thì chưa nhưng bạn vẫn gõ ko dấu nhanh mà.
    ví dụ: "tắc kè hoa" thì bạn gõ "tac ke hoa" là ra "tac-ke-hoa"
  10. hayboy

    hayboy Rất nhiệt tình

    Bài viết:
    314
    Được thích:
    65
    Thành tích:
    28
    Vẫn không được đâu bạn. Mình dùng joomla 2.5 mà.
  11. ==R==

    ==R== Mới tham gia

    Bài viết:
    18
    Được thích:
    2
    Thành tích:
    3
    sao ko bạn. bạn nói chỗ nào ko dc. mình đang xài k2 và j2.5 mà. bạn xem chữ ký trang của mình đang quản trị. mình tìm tòi và biết dc cái nào thì mình sẽ đưa lên cho bạn nào cần. mình làm dc mình mới hướng dẫn các bạn
  12. hayboy

    hayboy Rất nhiệt tình

    Bài viết:
    314
    Được thích:
    65
    Thành tích:
    28
    "tại mục advande SEF bật Yes phần Enable" mình tìm ở đấy rồi không có chỗ nào như bạn nói. nó chỉ có phần cấu hình: sh404SEF Integration
  13. ==R==

    ==R== Mới tham gia

    Bài viết:
    18
    Được thích:
    2
    Thành tích:
    3
    ghi đến như vậy rồi mà bạn vẫn ko nhìn ra.
    Tại mục advande SEF, tìm dòng Use the item ID in the URL chọn No
    Tại mục sh404SEF, tìm dòng Insert item ID in URL chọn No.
  14. ngô đức vũ

    ngô đức vũ Rất tích cực

    Bài viết:
    92
    Được thích:
    13
    Thành tích:
    8
    zzz đang cần cái alias TV không dấu, kiếm bữa h chỉ toàn hỗ trợ content chứ ko hỗ trợ k2,
    Ghi lại alias thực tế là không phiền phức và khó khăn,chỉ mệt ở chỗ nếu quá nhiều tin sẽ rất tốn thời gian :(
    mong chờ cao thủ giúp đỡ alias cho K2 :)
  15. hayboy

    hayboy Rất nhiệt tình

    Bài viết:
    314
    Được thích:
    65
    Thành tích:
    28
    mình cũng không hiểu luôn. có gì đâu mà mình không nhìn thấy 2 dòng đấy.chỉ là phần bạn nói:" tại mục advande SEF bật Yes phần Enable" nó không có.
  16. hayboy

    hayboy Rất nhiệt tình

    Bài viết:
    314
    Được thích:
    65
    Thành tích:
    28
    bạn lên google có hướng dẫn đó.
  17. hayboy

    hayboy Rất nhiệt tình

    Bài viết:
    314
    Được thích:
    65
    Thành tích:
    28
    m đã làm được rồi. m phải update k2 lên bản mới nhất.

Chia sẻ với bạn bè

Liên kết bạn bè: